cudnn90

shucks this is the max cuda for your nvidia driver version..
at least 361.00 is required for CUDA 8.0
at least 352.00 is required for CUDA 7.5
at least 346.00 is required for CUDA 7.0
at least 340.00 is required for CUDA 6.5
at least 331.00 is required for CUDA 6.0
at least 319.00 is required for CUDA 5.5

  • apt-get install ansible

and then

  • maybe save the below as cuda.yml and run ansible-playbook cuda.yml ?

- hosts: localhost
  #user: somebody
  #sudo: yes
  tasks:
    - name: register CUDA repository
      shell: wget https://developer.nvidia.com/compute/cuda/9.0/Prod/local_installers/cuda-repo-ubuntu1604-9-0-local_9.0.176-1_amd64-deb && dpkg -i local_installers/cuda-repo-ubuntu1604-9-0-local_9.0.176-1_amd64.deb

    - name: install CUDA
      apt: name=cuda update_cache=yes

    - name: write environmant variables to bash profile
      copy: src=./cuda.sh dest=/etc/profile.d/

    - pip:
        name: numpy

    - pip:
        name: Keras

    - pip:
        name: tensorflow-gpu

    #- pip:
    #    name: --upgrade $TF_BINARY_URL
    #  environment:
    #    CUDA_HOME: /cluster/apps/x86_64/packages/cuda_8.0
    #    TF_BINARY_URL: https://storage.googleapis.com/tensorflow/linux/gpu/tensorflow-0.11.0rc1-cp27-none-linux_x86_64.whl

  • install cudnn

cudnn-9.0-linux-x64-v7

libcudnn7_7.0.2.43-1+cuda9.0_amd64

libcudnn7-dev_7.0.2.43-1+cuda9.0_amd64

cudnn-6.5-linux-x64-v2

cudnn-sample-v2